It is currently Wed Aug 23, 2017 12:29 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Fri Aug 11, 2017 1:36 pm 
Offline
Got muddy boots
Got muddy boots

Joined: Fri Jul 25, 2014 7:01 pm
Posts: 20
so i have a problem atm , driving along the engine will just die and i will lose all power on the dash , then it wont start for a little while.

its a Suzuki samurai , 1992

recently i have changed the fuse board but it was working nicely for about 2 months now the problem

its got a 1.6 8v carb engine in it and i have replaced the leads and plugs so i know its not that.

any ideas are helpful ??


Top
 Profile  
 
PostPosted: Fri Aug 11, 2017 1:44 pm 
Offline
SCUK Addict
SCUK Addict
User avatar

Joined: Sun Apr 20, 2008 9:48 pm
Posts: 809
Location: Shepton Mallet
Do these have cam sensors?

_________________
Image
2002 Jimny O2 Ragtop
Safari Snorkel, Diff Breathers
G/Box T/Box Breathers
Goodyear Wrangler AT/SA+


Top
 Profile  
 
PostPosted: Fri Aug 11, 2017 1:47 pm 
Offline
Got muddy boots
Got muddy boots

Joined: Fri Jul 25, 2014 7:01 pm
Posts: 20
nope , to old for that


Top
 Profile  
 
PostPosted: Sat Aug 12, 2017 8:01 am 
Offline
I spend far too much time on here
I spend far too much time on here
User avatar

Joined: Tue Sep 09, 2008 5:32 pm
Posts: 4197
Location: Dorset or stuck
I had the engine die like this in my old one, turned out to be the coil, but sorry can't remember if it affected anything else

_________________
Sid James gone but never forgotten
Jimny 1.6 not as good as an SJ but still good


Top
 Profile  
 
PostPosted: Sat Aug 12, 2017 9:38 am 
Offline
The Boss
The Boss
User avatar

Joined: Tue Apr 15, 2008 11:13 am
Posts: 11090
Location: Chippenham, wiltshire
If all the electrics are dying, dash lights and all then check the wires and connections on the battery, there could be a dodgy connection that isn't obvious.

Maybe try briefly bypassing the fusible link (batt + to white with yellow), you can always replace this with a 45a fuse.

_________________
Zuki Build

Steady as she goes!


Top
 Profile  
 
PostPosted: Sun Aug 13, 2017 7:53 pm 
Offline
Got muddy boots
Got muddy boots

Joined: Fri Jul 25, 2014 7:01 pm
Posts: 20
update guys

all fixed now , it was the wire going to the carb , the carb cut off had rubbed a hole in itself and when it touched the body it was stopping the engine

found it by accident but still found it lol


Top
 Profile  
 
PostPosted: Sun Aug 13, 2017 8:16 pm 
Offline
The Boss
The Boss
User avatar

Joined: Tue Apr 15, 2008 11:13 am
Posts: 11090
Location: Chippenham, wiltshire
I was going to suggest the carb stop solenoid but that wouldn't normally kill all the dash lights :lol:

_________________
Zuki Build

Steady as she goes!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group